Navigation

Subscribe

Get the latest posts delivered right to your inbox.

or subscribe via RSS with Feedly!

I Hate Widgets

At the time that I am writing this, I am troubleshooting a problem with the widgets on the sidebar. I am considering just commenting them out because I can't seem to figure out why they aren't working.

![Featured Posts](https://s3-us-west-1.amazonaws.com/lumber-mike/pics/Featured.png)![Tags](https://s3-us-west-1.amazonaws.com/lumber-mike/pics/Tags.png)

They are supposed to look all nice and neat, like you see in the images above. My site isn't auto-populating these widgets and I can't seem to figure out why. I have all of the dependencies installed, the javascript is exactly the same as the source for the theme creator and it compiles, and there is data to pull the First! post data into both of these widgets.

On top of that, the search feature doesn't work. I'm wondering if there isn't some bigger problem with node that I'm not catching. I have no clue as of right now.

I have a few options:

  • Ditch this weird theme and go with something that works
  • Spend another day beating my head against the wall since the documentation doesn't explain anything about these widgets
  • Recruit the help of a friend who is an amazing developer, but doesn't mess around with Ghost
  • ~~
  • Give up and install WordPress
  • ~~

And guess what? When I click "Preview" in Ghost the widgets have magically started working! If this just needed two posts for it to work I'm going to ragequit for the day and rethink my troubleshooting processing...

Comments: